1. 2
    Link shared Programming Technology 6 months ago

    Codigniter 4.1.8 released. What's new?

    github.com
    BeerAndCode
    Here for beer or for code

1) Codeigniter 4.1.8 is a security update:

XSS Vulnerability in the API\ResponseTrait was fixed.

2) Codeigniter 4.1.7 brings the following main update:

FILTER_SANITIZE_STRING - replaced

3) Codeigniter 4.1.6 also brings some security updates, such as:

Deserialization of Untrusted Data found in the old() function was fixed.

fix: Validation cannot handle array item


As a conclusion, for security reasons you should always update to the last version of the framework that you're using, even if it's Codeigniter, Laravel, Symfony or others.

No reply yet